Youtube videos now broken due to V2 api

For all things BigCommerce.. Chat, sharing ideas, links to tips and ways to make things work.

Youtube videos now broken due to V2 api

Postby myshop » Thu May 28, 2015 7:14 am

Hi

The search for youtube feature in the images/video's tab of the add/edit product feature is now broken due to youtube shutting down their v2 api.

The videos that were previously inserted still play on the site - So the actual embedding code is still the same.. so its just the search function in the admin area thats the issue.

I would pay a bounty of $150 to get a fix to this.
myshop
 
Posts: 49
Joined: Tue Jun 23, 2009 5:48 am
Location: NSW Australia

Re: Youtube videos now broken due to V2 api

Postby myshop » Thu Jun 25, 2015 5:02 am

$200!
myshop
 
Posts: 49
Joined: Tue Jun 23, 2009 5:48 am
Location: NSW Australia

Re: Youtube videos now broken due to V2 api

Postby Martin » Fri Jun 26, 2015 9:53 am

Ah... so that's what happened... Did wonder...

Do I hear $300? ;)

Will see if I can find an easy fix but don't know the API for youtube so may be false hope at this point..
Martin
Site Admin
Site Admin
 
Posts: 1853
Joined: Wed Jun 17, 2009 6:30 pm
Location: South Yorkshire UK

Re: Youtube videos now broken due to V2 api

Postby Martin » Fri Jun 26, 2015 11:37 am

Hmm... ok... Taken a look at the code and it seems there's a few files that need altering (probably more I haven't found yet) so I'll make some notes and see what I can come up with...

  1. API version 2 used XML in the response so any calls need to be reinterpreted to use JSON arrays, not XML
    Files to attack:
    • lib/class.youtube.php
    • admin/includes/classes/class.remote.php
  2. Need the PHP libs for Google API
  3. Need to understand the process required for authenticating any API requests (do we need for basic searches I wonder?)

Looking at it, it seems like it should be relatively simple to achieve the basics of getting some results... Pagination of results looks to be more difficult due to the way the API won't accept start-index anymore but requires a token generated in the original search request..

I'll see what I can do when things are less frantic... And I'll hold you to that $200 if I manage it but it'll be going to charity... ;)
Martin
Site Admin
Site Admin
 
Posts: 1853
Joined: Wed Jun 17, 2009 6:30 pm
Location: South Yorkshire UK

Re: Youtube videos now broken due to V2 api

Postby myshop » Thu Jul 02, 2015 3:59 am

Hi

hehe.. ok sounds good. $250 it is - get a move on :-P
myshop
 
Posts: 49
Joined: Tue Jun 23, 2009 5:48 am
Location: NSW Australia

Re: Youtube videos now broken due to V2 api

Postby wurdz » Wed Sep 09, 2015 4:34 am

Hi all! I just finished updating and testing ISC 6.1.x Youtube API v3 integration. Wow, what a pain! :D There were a number of changes needed....

Read about it here: http://modirific.com/interspire/youtube-api-version-3-update/
Contact us here, if you're interested in purchasing: http://modirific.com/contact

Image

Best regards,
Jon Catoe

P.S. I'm working on some other fixes, updates, upgrades, improvements, and general awesomeness....
wurdz
 
Posts: 3
Joined: Sun Dec 11, 2011 8:39 pm

Re: Youtube videos now broken due to V2 api

Postby myshop » Fri Nov 13, 2015 5:25 am

I got another programmer to sort this out for me.. Ended up only needing to edit a small handful (4 I think) files.. Works well, but requires a youtube API Key (free)
myshop
 
Posts: 49
Joined: Tue Jun 23, 2009 5:48 am
Location: NSW Australia

Re: Youtube videos now broken due to V2 api

Postby Martin » Tue Mar 22, 2016 2:49 pm

myshop wrote:I got another programmer to sort this out for me.. Ended up only needing to edit a small handful (4 I think) files.. Works well, but requires a youtube API Key (free)

Glad you got it fixed... I was suitably awful at getting to it... Just no time to actually sort it out and got worse with arrival of a baby girl back in October.

What did it end up costing you?
Martin
Site Admin
Site Admin
 
Posts: 1853
Joined: Wed Jun 17, 2009 6:30 pm
Location: South Yorkshire UK

Re: Youtube videos now broken due to V2 api

Postby myshop » Mon May 02, 2016 12:56 am

Hi Martin

Was cheap :-) I had a local programmer sort it for me. From memory $100 AUD.

Edit: Was actually 400. hehe
myshop
 
Posts: 49
Joined: Tue Jun 23, 2009 5:48 am
Location: NSW Australia

Re: Youtube videos now broken due to V2 api

Postby Martin » Thu May 05, 2016 5:04 pm

myshop wrote:Was cheap :-) I had a local programmer sort it for me. From memory $100 AUD.

Edit: Was actually 400. hehe

LOL... Mates rates eh? You sure it wasn't 1,600 USD? ;)
Martin
Site Admin
Site Admin
 
Posts: 1853
Joined: Wed Jun 17, 2009 6:30 pm
Location: South Yorkshire UK


Return to [BC] Community Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron